Users are unable to purchase a subscription to Openfit
Incident Report for Openfit.com
Resolved
This incident has been resolved.
Posted Apr 23, 2019 - 08:36 PDT
Monitoring
A fix has been implemented by our third party payment provider Recurly and we are monitoring the results.
Posted Apr 23, 2019 - 08:14 PDT
Identified
Our payment provider Recurly has identified the issue impacting service availability and is working to fully resolve it. For more details see status.recurly.com
Posted Apr 23, 2019 - 07:42 PDT
Investigating
We are currently experiencing issue with payments. We are working with our payment gateway provider Recurly to restore service. For more details visit status.recurly.com
Posted Apr 23, 2019 - 07:17 PDT
This incident affected: User Registration.