Users are unable to purchase a subscription to Openfit
Incident Report for Openfit.com
Resolved
After making sure that our 3rd party sho pages are stable we have resolved this incident.
Posted Jun 02, 2019 - 17:28 PDT
Investigating
The Openfit shop page is currently unavailable. We are working with our 3rd party shopping cart provider to resolve the issue.
Posted Jun 02, 2019 - 13:43 PDT
This incident affected: Shop.